Debian on Artik 5 - No Network

I followed this guide (Debian: Getting Started with the ARTIK 5) to create a bootable SD for my Artik 5, which worked great (Thank you @RobertCNelson), however no network devices are showing via ifconfig besides loopback. I have tried all three kernel options with the same results across all. Any guidance on enabling eth/wifi?

Hi @advacomp , i’ll need to look thru my collection of boards at home.

I’m trying to remember if i even had network working… Samsung had ended this project before we fully figured out everything interface for mainline, before all documents got pulled…


@RobertCNelson - Thank you! My end goal is to get the Artik 5 running with networking on a 4.0+ kernel that supports overlay2 for docker. It’s been a journey trying to dig up information on this discontinued board. I’m currently exploring what I can do with Yocto.

Nice, this board did go mainline:

The ethernet adapter is connected on the spi bus… try modprobing the asix driver?


Thank you for the tip @RobertCNelson. I tried modprobing your v4.15.x-artik-armv7 (Prepatch) but still nothing coming up with ifconfig -a