Micron 2GB unable to set WEL bit


I am unable write data because I cannot seem to set the Write Enable Latch in the Feature status register. All SPI signals are verified correct to the datasheet on an oscilloscope. I can read the device ID register and get the correct data reply. The external pins WP# and HOLD# are wired to 3.3V. The CS# pin has a pullup so that it rises with VCC on powerup, as per datasheet.

I set the Write Enable Latch bit according to the datasheet: CS low; 06h (WRITE ENABLE command); CS high; (delay); CS low; FEATURE command for status (1Fh, 0Ch, dummy_byte); CS high. The chip serial out pin goes low and sends 00h at the end of the command. Status and all other Feature registers also read 00h. I expect 02h for the WEL bit set instead.

Do need to do something before I can set the WEL bit? I cannot find anything else in the datasheet. I have tried two parts.

Hello, welcome to the Techforum! I have reached out to our product specialist about this to help troubleshoot why you are unable to write data to this part. Technical reference number T4646586

I made a typo above, FEATURE command for status (1Fh, 0Ch, dummy_byte)
should be FEATURE command for status (0Fh, 0Ch, dummy_byte).

It is correct in my code. I copy-pasted here from the wrong paragraph of the DS.


I will send the updated request to the Product Specialist.

Solved. My typo in code was 0x0C for status register address. Correct address is 0xC0. Now everything works. Note for others: part ships with all blocks write protected. Bits must be cleared in Feature Block Lock (address 0xA0) to enable writing to address block ranges.

1 Like

That is awesome. Thank you for letting us know.