Shawn Hymel's iCE40 FPGA series: apio command not working

Short version: I’m stuck on video #2 around 12:30–“apio verify” just gives me an error. Two images attached. Thanks!

Hey! I’m a student trying to learn FPGA’s and build a project portfolio by January. My goal, as of right now, is to get an embedded design job/internship (FPGAs, MCUs) for next summer, but I need to start applying early. This project is my first step to getting back into FPGAs after the one class I used them in, two years ago.

Possible causes:
I’ve previously had issues with apio and the icestick folder being in an unexpected path, and I have to type the full path each time. I’m wondering if the strange path could confuse my toolchain. I checked, and I believe that I have all the toolchain pieces I need (yosys, gtkwave, etc.).


we are looking into this and should respond shortly.

Thank you

Ryan Urness

1 Like

apio needs python to be added to the path:



Thank you for your quick response! You’re right, I needed to add it to the path–now, I can check “–version” and get the proper response.

I still need to figure out how to use “apio verify.” I’m typing the same command as Shawn, but I can’t seem to get it to work. Is this also a path issue? This is my first time working with command prompts.

Thank you!

Solved myself:
In the video, Shawn uses an old version of Python and an old version of Apio. Installing the updated versions of both programs now allows me to call “apio verify”.

You’ll need to “add an environment variable” (it was an option when I reinstalled Python, but you can find the option in the Windows search bar), too, but adding Python and Apio to the path will only solve the issue if the most recent versions of Python/Apio are installed.

1 Like