RE: PICO-PI-IMX7 and Siging In/Um?


#1

Hello,

I see how the Linux dd cmd can be used to put an image on the board. I have a PICO-PI-IMX7 w/out SD Card.

It is a base model, I guess. It has a “following” so far.

But, even w/ this following, I have been unable to use Serial or SSH to sign in b/c I have been unable to find the COM port or IP Address.

If you know how to find these items from this board while on a Win 10 computer, please let me know. I went to the router to find the IP Address. I have been unable to sign in via that specific IP Address. Aw!

I have access to a Linux Desktop but not at the moment.

Seth

P.S. If you know what I am discussing, please start a chat w/ me on this idea.


#2

@silver2row, that board ships with Android Things, you should get serial access thru the Micro USB debug header on the side of the board.

PICO-PI-IMX7

Regards,


#3

@RobertCNelson,

Hello Sir…thank you. I just understood.

Seth


#4

Hello Again Sir,

Okay…I connected via serial console via PuTTY on Win 10. Should I use a different program when serial’ing in on the Android Things board we are discussing?

I have no prompts or anyway to sign in right now. I think I have to use an online, “cloud” app for using this item so far. Do you think it is possible to run Ubuntu on this machine? If so, I have a way to get the Ubuntu 16.04 LTS image for the board. They have it on their site, Wandboard.com.

Seth

P.S. I will keep researching the ideas about this board. As of now, I am getting an Android Things Utility. I have it and the command prompt understands commands. Here is a screen shot of that utility to set up Android Things on the PICO-PI-IMX7 board.

DigiAndroid


#5

Hello Once More,

If people are using this dev. board, please contact me. I would like to know what options are available for programming the board. I have been reading the online docs. and finding other options that are available.

Options like setting up the board for use, making WiFi available, and using the header pins are all something that seems unlikely to me. I am sure I am missing something valuable.

So…

If you are using the board and have access to it, please do not hesitate to reply.

Seth


#6

@silver2row, here’s a quick pass, still working on merging the kernel config changes required…

https://www.digikey.com/eewiki/display/linuxonarm/PICO-PI-IMX7

Things get interesting as we need to use U-Boot’s dfu and ums mode to write date to the eMMC.

Regards,


#7

Hello Sir,

You do not know how grateful I am right now. I will just say this, “Thank you.” I dealt w/ Wandboard people and they redirected me to Tech Nexion, “They produced the boards.”

Anyway…I am on Linux now. I will update you later. I am going to try and solve this issue of having no connection.

Seth


#8

@silver2row, here’s the patch i used:

and the kernel repo that boots. (i’m getting a weird ip address over eth0…)

git clone -b v5.0.x https://github.com/RobertCNelson/imx_v6_v7-mainline-linux --depth=10
cd ./imx_v6_v7-mainline-linux/
./build_kernel.sh

Regards,


#9

Hello,

Okay. I got up to the point when I need to read the SPL file, e.g. sudo ~/imx_usb_loader/imx_usb SPL in the u-boot dir.

Seth

P.S. The terminal states: Cannot read from file SPL.


#10

@silver2row, that file is generated when you build u-boot:

https://www.digikey.com/eewiki/display/linuxonarm/PICO-PI-IMX7#PICO-PI-IMX7-Bootloader:U-Boot

Regards,


#11

@RobertCNelson,

Sir…I will rebuild u-boot but I think there may be bigger problems. I do not have an SD Card port on this board.

Seth

P.S. Does this matter for what I am doing while following the instructions?


#12

Hello Sir,

I got the patch building now. I will keep you updated.

Seth


#13

@silver2row, correct there is NO SD Card on this board, that’s why we are using U-Boot’s ums function:

Power Board and enable U-Boot USB Mass Storage mode:

**U_BOOT_TERMINAL**

`=> ums 0 mmc 0`

What this does, you’ll find a new usb mass storage on your linux desktop, which just happens to be the board’s eMMC routed thru the usb interface. (thru u-boot)…

Regards,


#14

@RobertCNelson,

I will try to make it to that point again.

cc1: error: bad value (‘generic-armv7-a’) for ‘-mtune=’ switch

Seth

P.S. I am receiving this error. It gives me a list of items to use instead of switch. What should I do?


#15

You either swapped terminal windows, or skipped over this step to set CC…

https://www.digikey.com/eewiki/display/linuxonarm/PICO-PI-IMX7#PICO-PI-IMX7-ARMCrossCompiler:GCC

Regards,


#16

Hello Sir,

Okay. I got through the section I failed at beforehand. I got spl and u-boot.img to register.

Now, how do I get to the u-boot terminal? I have been reading and I see that I just use the esc character key on the keyboard. Is this true? If so, when should I perform this action?

Seth

P.S. I am sorry for this random questioning. Do I use the serial terminal on the PICO board after SPL and u-boot.img have been configured?


#17

@silver2row, i tweaked that section of the wiki this morning. Hopefully it’s a little clearer, if not we can tweak it some more. Essentially, plug in a 2nd usb cable into the “console” port, and break into u-boot and run the commands shown.

Regards,


#18

Hello Sir,

Thank you. I tested the new info. I am still stuck on SERIAL_CONSOLE_U_BOOT. The board does not go into u-boot mode. Should I use a program other than the Ubuntu (desktop) terminal? I set the jumpers for USB Boot and it loaded the SPL binaries and u-boot.img binaries.

After that, nothing happens. I pressed a key (any key) and I received no prompts signifying I was in u-boot mode.

Seth


#19

@silver2row, i use the program “tio” for serial access, once the jumpers are set for usb boot mode, you need to load both the SPL and u-boot.img binaries thru: ~/imx_usb_loader/imx_usb… You ‘should’ see confirmation thru “tio” that SPL and u-boot.img loaded, with u-boot eventually starting.

Regards,


#20

@RobertCNelson,

Sir…I can access the serial console now. Updates will ensue. I tried PuTTY for serial. It worked at first. Now, I cannot sign back into u-boot serial mode once I unplug the board and try to set up the jumpers in u-boot USB Mass Storage Mode.

Do you have any pointers?

Seth