USB boot power supply problem

This is a “is this the right place”, combined with an “I don’t have any idea how to diagnose this” query.

I bought my RPi 5 from DigiKey Feb 18, 2024. It took me a bit of time to get the related components (required power supply, case 52Pi Mini Tower, Samsung 860 1TB SATA M.2) and case for the M.2 drive). I finally got the case put together, flashed the 860 from the Raspberry Pi imager V1.8, transferred the cables from the Pi 4, and powered the RPi 5 on.

I get a terminal window with the message “USB boot requires high current (5 volt 5 amp) power supply”. Since this is what I have, I tried the power supply on the Pi 4, which successfully booted. I’m not sure if that told me anything useful besides the power supply being functional.The RPi 5 then tried to boot by going into a boot loop.

The term messages continue to say that I could hit the power button to bypass the power check. Hitting the power button turned the thing off, so I tried hitting the reset button. The RPi 5 then stops retrying, finishing in a terminal window with no GUI, with initramfs as the prompt.

I have to wonder now if the Pi 5 itself has a problem. The only other thing to try is re-flashing the 860. What should I do next?


This Raspberry Pi Forum would be a good place to start.

Sounds like quite a bit of stuff potentially running off your supply, so it may need most of that 5A.

You didn’t mention which specific supply you are using. As I understand, the RPi-5 uses the USB-PD protocol to interrogate the supply as to how much current it can deliver, and if it doesn’t answer correctly, you’re likely to get such a message.

Here are supplies specifically specified to work with the RPi-5. Make note of the different options for different countries.

Here’s a link I found which is related to your issue.