Wandboard Quad on Arch refusing connections

Hello. I have a Wandboard Quad that was working fine after I installed Arch Linux ARM following these instructions: https://archlinuxarm.org/platforms/armv7/freescale/wandboard

The Quad serves as a small NAS serving media from an HDD connected to the SATA port to a Squeezebox Touch and to my desktop computer. As I say it was working fine, but suddenly it began refusing all connections (it does respond to a ping with no problem). Until now I have been connecting to the board using SSH from my desktop computer. The last thing I was able to do, as I recall, was to change the Locale from the default “C” to EN-US-utf8. But now every time I try to connect I get the “Connection refused” message. To me this implies that the board has booted.

So I tried connecting the board to a monitor via the HDMI port and plugging in a keyboard via the USB port. When I power on the Quad, I get the Wandboard.org logo on the screen, but after that nothing except a flashing HDMI port icon and then a “No Signal” message from the monitor. The keyboard seems to be responding, because when I hit Ctrl-Alt-Delete the board restarts and I see the Wandboard logo again, but after that “No Signal” again.

Any suggestions as to how I can troubleshoot would be appreciated. I’m ready to provide any information anyone might need.


I wouldn’t expect that change to break that either.

Can you login over serial console?

The original Wandboard quad’s has a bug in the EDID hardware circuit, you need to modify your boot arguments to append a your selected video resolution. Something like:




Is what i recommend for my Debian instructions, but for ARCH it’s probably similar but different. It also helps, if your monitor has a built-in usb hub, to connect that directly to the Wandboard to help share the GND plane between both devices.


Thanks! No, I haven’t tried to connect via the serial port. Is there an advantage to that? Would it bypass the problem connecting via HDMI?

As I mentioned, the board was working when it was operating headless just as a server.

I can plug the card in with an SD card reader and make changes via my Linux desktop PC. Is there a setting I can change that way to make the video work?

@Lestrad, you should be able to login over serial, it’ll be the same experience as ssh, so you should be able to login into the system.

Sadly, I mostly support Debian on these SBC’s, so no personal experience with ARCH, but it should have a configuration file u-boot loads on bootup, where you could set the video parameters. If you plug in a serial adapter, you should see u-boot either load-up something, or allow you to override the bootargs.


Thanks a million. I’ve had so many problems with Arch that I was contemplating switching to Debian. Also, help is simply not forthcoming from the Arch and Arch-ARM forums, although I’ve struggled to do the homework and try to ask informed questions (and to be forthcoming with help where I can). As for the Wandboard forum, it seems to be pretty much a ghost town, except for the fact that it’s full of spam. (In fairness, Wand was supposed to be a volunteer project.) Anyway you, Sir, are truly a godsend.

I have a USB->null modem cable on order. I’ll post here as soon as I get it and give it a try.
Meanwhile, any ideas as to what could be refusing connections would be much appreciated.