Can't drag and drop any component

Hello I just try to start with Scheme it and It is just impossible to drag and drop any component. How can we allo the drag and drop.
I have started a new project but still the same. I tried with Chrom and explorer still the same actually I can not do anything with this software.
thanks

Hi Pidofra welcome to TechForum. You might what to clear your cookies and cache to see if that works, and verify that you are registered and logged into Digi-Key. If it still does not work, you might restart your computer to see if that might just be a glitch in logging in. Please see the link below for a help document below that might be of help. Glenda

Hi @pidofra! I’d also encourage you to check out this tutorial video.

Kind regards,
Brian

Hello

Look I tried everything you said.

I cleaned all the cookies and so on,

I watched all the videos on utube already regarding digikey and scheme it.

But still the same, after loggini, When I grab a resistor for example drag and release it simply disappear, doesn’t stay on the sheet same with other component.

So

image001.jpg

image002.png

One other way to select symbols/components is to double click on them, maybe try that?

(? @Cody_Walseth )

I did but it doesn’t work either

If I click and drag then I can see the chosen component moving over my sheet but as soon as I release the left click it disappears

Thanks.

image001.jpg

image002.png

Hi @pidofra a couple things you can try:

  • Clear browser cache
  • Make sure you have JavaScript enabled
  • Try using your browser’s incogneto/inPrivate window - some browser extensions may cause issues and this will rule those out.