Getting 403 Error for months!

I can not use your site because I keep getting the “403 - Click Here to Report this Error:” on ALL my browsers. I never had this issue in the past, what’s going on? Yes, I X’d out my public IP, please let me know if you can help.

No VPN in use

Hello @AlHarley

Let me reach out to our webmaster and see if they can identify the issue you are running into.


Welcome to the forum.

This problem is all too common across the whole internet, Microsoft has a number of troubleshooting pages for their various web properties that cover specifics for those properties. All of Microsoft’s pages suggest two common problems that can be the cause in all cases.

  • You are running personal firewall software or some other security, download assistant, or web accelerator software.
  • The Hosts file is damaged or contains incorrect information.

Perhaps that will help you troubleshoot the problem while you wait for Dig-Key’s great web guys to offer some suggestions.


Was there a specific page you are on or a specific activity you are doing when you get the error?


All of it is blocked

Nope, I’m not running any of the software you mentioned. I have also tried to access your site on 4 separate laptops, a second desktop, and my mobile device. As long as I’m on my network I have no access to your site, AND ONLY YOUR SITE. However, when I am NOT on my home network I am able to access the site without any issues. Digikey is the ONLY site I have issues with, and after researching the issue online I learned that this is an ongoing issue with I believe that for some reason, your site has blocked my private IP address because the 403 error shows that address on the end of the error. Thank you for your time, I’ll be waiting for your reply.

Sorry to hear that.

FYI - I am only a user here like you, hopefully the Digi-Key people can help.

Thank you for your input! :slight_smile:
And yes, hopefully they can take care of this issue.

This smells like a block somwehere, so here’s a shot in the dark… (Assuming windows, start the cmd prompt (window key - r) cmd)

Please run:

  • nslookup
  • tracert
  • tracert
Server:  pi-hole

Non-authoritative answer:

Tracing route to []
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms
  2     9 ms     8 ms     7 ms
  3     8 ms     8 ms     7 ms []
  4    11 ms    10 ms    10 ms []
  5    10 ms    11 ms    11 ms []
  6    29 ms    32 ms    29 ms []
  7    29 ms    29 ms    29 ms
  8    31 ms    30 ms    29 ms
  9    30 ms    29 ms    31 ms []

Trace complete.

Tracing route to []
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms
  2     8 ms    12 ms     6 ms
  3     7 ms     6 ms     7 ms []
  4    11 ms    14 ms    11 ms []
  5    10 ms    10 ms    10 ms []
  6    18 ms    19 ms    15 ms []
  7    31 ms    26 ms     * []
  8    22 ms    26 ms    24 ms []
  9    32 ms    31 ms    30 ms []
 10    40 ms    38 ms    38 ms []
 11    39 ms    38 ms    38 ms []
 12    34 ms    34 ms    34 ms
 13    46 ms    47 ms    45 ms
 14     *        *        *     Request timed out.
 15    51 ms    50 ms    50 ms

Trace complete.



@AlHarley would it be possible for you to msg me your IP address so my IT team can make sure it is whitelisted?


Yes, I can do that. Is there way I can send it to you so it’s not listed on this forum for all to see?

Sent you a private message.

I am running Windows 10 Pro, and was able to use cmd to enter the commands you sent. But I am not able to post full the results because of all the text that comes up as “links”. How can I get these results over to you?


Doh! Either use or add it a as a file.log


LEtWXsaW.txt (2.1 KB)

Here is the pastebin file, will this do?


Thanks @AlHarley, everything looks fine from your log… IDK, It’s got to be a block in your browser somewhere. Very strange…


I would agree except that using the same browser on a different network doesn’t produce the same error. As I was researching this issue, I came across other users with the same issue and it seems to be resolved on the end. I have been able to place orders through my Galaxy Note9 as long as I use my data plan and not my inhouse WiFi, and again, same browser, I know that they will get to the bottom of this issue, meanwhile I’ll patiently wait. Thank you for looking into it! :+1:t3:

If you post links to those cases it might help the web team troubleshoot the problem.


Please try to access the site when you have a chance and let me know if you are still getting the error.

Thank You

It’s working again. Thank you Robert! I’m glad we were able to get to the bottom of this issue. Would you please explain what the problem was?
Thanks again,