Is there a rootfs version of Ubuntu server 22.04 out there for armhf/Beaglebone Black?

Hi all,

I am trying to install Ubuntu server 22.04 on a Beaglebone Green Wireless and am wondering where I can find a rootfs version of Ubuntu server 22.04 so I can follow the guide for the Beaglebone Black for installing debian. I have checked on the Ubuntu website and they only have pre-installed versions for the raspberry Pi and armhf. I have tried installing these with belenaEtcher but the board won’t boot from the SD card. I am assuming these pre-installed images aren’t working because they are written for the rasPi environment, and not the Beaglebone Black. Is there any way to get them to work or am I stuck with an older version for Ubuntu Server?


Sorry not at this time, just 18.04 and 20.04 weekly snapshots are avaible: Index of /rootfs

idk, let’s see what’s changed… ubuntu: 22.04 · RobertCNelson/omap-image-builder@567998f · GitHub

Here you go, totally untested: Index of /rootfs/ubuntu-armhf-22.04-minimal

Built via: omap-image-builder/ at master · RobertCNelson/omap-image-builder · GitHub so if you want to change anything.


1 Like

Thank you! I was able to get it working, but I am having trouble connecting the board to wifi. I installed connman but my wifi network doesn’ show up when I run connmanctl services. Do I need to install a driver for the wifi chip or do I just need to fiddle around with the network settings of the BBGW?

(edit: I was able to get it connected after a simple reboot)

now I am trying to connect to bluetooth but the command bb-wl18xx-bluetooth is not found. I tried to update the package with apt and also tried to install the driver for wl18 from TI’s website. But it still is not found. Do i need to rebuild the image with a different version of the wl18xx firmware?


sudo bb-wl18xx-bluetooth-hciattach


1 Like

I am trying to create a custom image with some added packages by following your guide on the omap-image-builder github but I have run into the issue of the image not booting on the beaglebone. Do I need to specify that I am trying to install it on a BBGW? I would think it the green wireless wouldn’t change much from the black given they use the same processor. Do you have any ideas of what might be the issue? Thanks for your help

Hi @Raif33 , as long as you ran “” like shown: omap-image-builder/ at master · RobertCNelson/omap-image-builder · GitHub it should boot…

Feel free to share your serial boot log and i’ll take a look at it…