PIC18F67K40 - Failed to get device ID

I am using PIC18F67K40 and PICKIT3 with MPLAB 8.92V for programming. But I am getting error:

Failed to get device ID

I have attached schematic snap of MCLR circuitry. I am able to program other board using the same kit, so I am not suspecting malfunctioning of kit.

So far I have tried below:

  1. Using external supply for target
  2. Setting different voltage in settings of MPLAB
    3.I remove capacitor and tested , still the same

Your circuit violates some of Microchip’s recommendations. Check the literature for the specific Microchip programmer you are using.

In particular the capacitor on MCLR and the series resistors on the programming/control lines. I’d start by removing C8, and shorting out R15, R16 & R22.

Once it’s working you can try adding the resistors back. However depending on the specific programmer, PCB trace and programming wire capacitances, the resistors may cause a hard fault or even worse a randomly intermittent fault.

NOTE: Beware of older ICSP documents that are still hanging around they are for older style parts and older design programmers. The 1990’s and 2000’s recommendations may not work with modern parts and programmers. Check that any document you are using is from 2014 or later.


Can you verify that your project in MPLAB 8.92 is set up to use the PIC18F67K40? This device does not appear on the supported device list for MPLAB 8.92.

Every microchip device has a unique ID and if that does not match what your project is set up for it will error out when trying to program.

Reid L.