RE: PICO-PI-IMX7 and Siging In/Um?


#108

@silver2row

Click on this link:

https://www.digikey.com/eewiki/display/linuxonarm/PICO-PI-IMX7#PICO-PI-IMX7-Bootloader:imx_usb_loader

Then scroll down to here:

That’s where you should be…

Regards,


#109

Okay,

Sir…the link gave me the run-around or something. I got you now but I should be in eMMC Boot Mode and not USB Boot Mode. I am in USB Boot Mode right now b/c I was planning on starting from scratch. I will change to eMMC Boot Mode now. Bear w/ me.

Seth

P.S. I will be back in a bit.


#110

Okay…@RobertCNelson:

Sir, I got in eMMC Boot Mode again and I am in u-boot but I had to get into u-boot by using these commands:

sudo ~/imx_usb_loader/imx_usb SPL

and

sudo ~/imx_usb_loader/imx_usb u-boot.img

I am building the kernel right now while in my dev. desktop and in the u-boot console w/ ums 0 mmc 0. Right?

Seth

P.S. Is there anything I should check right now before proceeding?


#111

Okay…@RobertCNelson:

I am on the mount partition section and I already see that my system is mounted at /media/rootfs/.

I think this is the point where I went awry. I was mounting things that were already mounted. I will update you soon.

Seth

P.S. Also sir, this command, sudo sh -c "echo ' append root=/dev/mmcblk2p1 ro rootfstype=ext4 rootwait quiet' >> /media/rootfs/boot/extlinux/extlinux.conf", is confusing me at root=/dev/mmcblk2p1.

Should I turn root=/dev/mmcblk2p1 to root=/dev/sdb1? I am asking b/c I already tried this idea. I tried root=/dev/sdb and root=/dev/sdb1. Please send guidance.

P.S. Please reply when you have time.


#112

umount: /media/rootfs: not mounted.

Sir,

@RobertCNelson, this is the print out on the terminal once I perform the umount command.

Seth


#113

No you should NOT change that. That is a variable read by u-boot “running” on the PICO-PI-IMX7 that is passed to the kernel booting on the PICO-PI-IMX7 to determine the “root=” aka Root File System location (onboard eMMC).

If you were to “change” that you better make sure there is a disk/partition plugged into the PICO-PI-IMX7, otherwise it will halt and complain about un-able to find the Root File System (you’d actually need “two” usb flash drives plugged in, as one would be /dev/sda and the other /dev/sdb) .

Reminder, most of the wiki can be copy and pasted directly “as-is”, there are only a few situations documented where you need to determine something and either set a variable (export DISK=/dev/sdb) or choose one of two options.

Regards,


#114

That’s a sign that you skipped this step:
PICO-MOUNT

Start over again, but you’ll probably have to remove “/media/rootfs/” as it now contains a random armhf based root file system.

sudo rm -rf /media/rootfs/

Remember: Copy and Paste every section as written, skipping no steps…

Regards,


#115

Yes Sir,

I see now that we are exchanging the file system from xx to xxx. I just need to follow the instructions w/out question. Yes sir.

Seth

P.S. I will be right back.


#116

Hello Sir,

That is exactly what happened. I had to figure out how to get out of having two /media/rootfs systems on my desktop. That was an odd day.

Seth


#117

Sir,

Seth here. Okay, first off. Let me thank you for hanging in there w/ me. I know I made mix-up after distraction. So, for this final time, I got it to allow me to sign in.

But…yes but.

The issue remains, I think there is a failed cpu b/c of this line (even though I can sign in to a system): CPU 0 failed to init idle CPU OPS.

If this is just a random occurrence, okay. I can live w/ the issue for now until I get the system “fixed-up.”

Seth

P.S. You rule, duder. Thank you again, sir.


#118

That’s not a “failed” cpu, that’s the cpuidle “driver” either the imx7 is too new and support for cpuidle hasn’t fully matured, or it’s already fixed on mainline.

Regards,


#119

Sir,

Oh. I will look into that right now. Thank you for all your reading capabilities, i.e. even when I made no sense at all. Thank you!

Seth


#120

Sir,

I rebooted the device. I cannot sign in via ssh. I forgot to check the ip addr w/ that cmd.

Seth

P.S. What in the world do I do now?


#121

Login over serial console, and type “sudo ifconfig -a” then write down the ip address…

Regards,


#122

Yes Sir,

I am going off to do that now.

Seth


#123

Hey Sir,

I have issues. My desktop is not locating this “drive” on my computer. The PICO board is not showing up. I tried /proc/partitions and lsblk. Where else would I look? I will check sudo ifconfig -a on the desktop. I will check that out now. I can undo the automount on this device/the desktop and try that way.

Seth


#124

No, run “sudo ifconfig -a” from the PICO-PI-IMX7 to find out what ip address it has, while it is running Linux.

Use the USB console port to login to the PICO-PI-IMX7…

Regards,


#125

Hello Sir,

I tried to sign in. Should I try w/ u-boot again? I cannot contact my board in any other method so far.

Seth


#126

Username is “debian”, password is “temppwd”…

Please show the exact error message you are getting when you try to login thru the “USB” Serial console port of the PICO-PI-IMX7…

PICO-SERIAL

Regards,


#129

@RobertCNelson,

Everything works now. I had to restart the dev. desktop.

Seth

P.S. Thank you again, sir.