STM32WLE5CCU Sleep Mode Issue


I had some problem with connection test board to “LokalConcentrator” Nucleo Board.

I had tried to run sample from STM32CubeIDE “ LocalNetwork_Concentrator” and “LocalNetwork_Sensor” projects.

We have two NUCLEO-WL55JC1 boards and one test board with STM32WLE5CCU.

One Nucleo board is “LocalNetwork_Concentrator” and another Nucleo board is “LocalNetwork_Sensor”. The test board must work like as “LocalNetwork_Sensor”.

I had modified “LocalNetwork_Sensor” project for test board, had created a new project(for ex. it will be named “LocalNetwork_Sensor2”) in STM32CubeIde( for base project configuration had been used “SubGHz_Phy_PingPong” project).

I hat tested project “LocalNetwork_Sensor2” on Nucleo & test boards, difference is in configuration files(stm32wlxx_nucleo_radio.c and stm32wlxx_nucleo_radio.h).

It works for Nucleo-Concentrator(had “LocalNetwork_Concentrator.bin”) and Nucleo-Sensor2(had “LocalNetwork_Sensor2.bin”), but test board(had “LocalNetwork_Sensor2.bin”) received wrong beacon and couldn’t established connection with “Nucleo-Concentator” board.

For example:

Nucleo-Sensor2 received always 0x010017bb beacon, but test board received different values with some repetition(0x3a310add, 0xfafd2c55 and etc.) For test board were RSSI&SNR values near RssiValue=-43 dBm, SnrValue=-1dB, Nucleo-Sensor2(without antenna) had RssiValue=-62 dBm, SnrValue=8dB, but Nucleo-Concentator have antenna.

I checked also, if test board may be catching another beacon. When I had shut down Nucleo-Concentrator, test board had not catch something and was not output in terminal some beacon data.

For test board configuration(im1.png):

-not supported PB0-VDD_TCX0

-used only RFO_HP, RFO_LP is not used

For Nucleo-Sensor2 used configuration by default.

In “sys_conf.h “are defined




In LocalNetwork_Sensor2.ioc->Middleware->SubGhz_PHY in SubGhz_PHY application tab:

Modemused: LoRa

Region: Region Europe freq. 868

LoRa bandwidth: 0: 125 kHz

LoRa SF: SF11

LoRa CR: 1:4/5

LoRa PREM length:8

LoRa symbol timeout: 5

LoRa fix length payload on: NULL

LoRa IQ inversion: NULL

Payload Length: 64

For testing test board RF configuration(work Radio or not), I had run “SubGHz_Phy_PingPong” project(“SubGhz Tab” configuration are how in LocalNetwork_Sensor2.ioc, but LoRa SF=7) between test board and Nucleo Board. It was worked.

RSSI&SNR values in this case are:

TestBoard: RssiValue=-87 dBm, SnrValue=11dB

Nucleo-PingPong: RssiValue=-84 dBm, SnrValue=12dB

Thank you for your help.

Best regards,