STM32F401RE - NRST held low

I started tinkering with Nucleo STM32F401RE. I was just blinking led succesfully at PA0 pin and suddenly the problem occured.

The CubeIDE gives me an error code when I’m trying to program it (Target Held under Reset).

I measured the Voltage on NRST pin (68mV). So I think something is holding the NRST pin LOW all the time.

I have tried different boot methods with Cube programmer but none of them have worked. I suspect there is something wrong with the board (maybe something shortcuts the NRST to GND)?

Does anyone have any suggestions?

Hello Vale Niskanen,

Thank you for your inquiry.

Per Page 22 of the datasheet for STM32F401RE

In regulator OFF mode, the following features are no more supported:
• PA0 cannot be used as a GPIO pin since it allows to reset a part of the V12 logic power
domain which is not reset by the NRST pin.
• As long as PA0 is kept low, the debug mode cannot be used under power-on reset. As
a consequence, PA0 and NRST pins must be managed separately if the debug
connection under reset or pre-reset is required

Thanks Kristofer for your answer.

As far as I understand the nucleo board (STM32F401RE) has LQFP64 package. So does this chip even have the Regulator OFF option(page 22)?

Also I’m quite beginner with these boards so I would appreciate little more help/instructions with the issue :slightly_smiling_face: